[Rozwiązany][ubuntu 18.04] problem z ustawieniami (?)

Linux jako system PC i Embedded
Regulamin forum
Aby łatwiej poruszać się w zagadnieniach to prosimy aby w temacie, na samym początku, w nawiasach prostokątnych umieszczać hasło wiodące dla opisywanego problemu np. [Debian], [System embedded], [Linux Mint] itp.
Awatar użytkownika
wojtek
Geek
Geek
Posty: 1926
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

[Rozwiązany][ubuntu 18.04] problem z ustawieniami (?)

Postautor: wojtek » niedziela 19 sie 2018, 19:19

Po wpisaniu np:

Kod: Zaznacz cały

wojtek@ubuntu:~$ sudo ./somlabs-debian/chtoolchain
[sudo] hasło użytkownika wojtek:
root@ubuntu:/home/developer/source/somlabs-dts-1.0# dpkg-buildpackage -us -uc

dostaje na dzień dobry jak niżej

Kod: Zaznacz cały

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
   LANGUAGE = "pl:en",
   LC_ALL = (unset),
   LC_TIME = "pl_PL.UTF-8",
   LC_IDENTIFICATION = "pl_PL.UTF-8",
   LC_TELEPHONE = "pl_PL.UTF-8",
   LC_NUMERIC = "pl_PL.UTF-8",
   LC_ADDRESS = "pl_PL.UTF-8",
   LC_NAME = "pl_PL.UTF-8",
   LC_MONETARY = "pl_PL.UTF-8",
   LC_PAPER = "pl_PL.UTF-8",
   LC_MEASUREMENT = "pl_PL.UTF-8",
   LANG = "pl_PL.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System Ubuntu 18.04 (64 bit) - jak pozbyć się tego dziadostwa? W poszukiwaniach i próbowaniu zalecanych rozwiązań dotarłem do końca internetu i nic się nie zmieniło
73 Wojtek

Awatar użytkownika
mokrowski
User
User
Posty: 167
Rejestracja: czwartek 08 paź 2015, 20:50
Lokalizacja: Tam gdzie Centymetro

Re: [ubuntu 18.04] problem z ustawieniami (?)

Postautor: mokrowski » niedziela 19 sie 2018, 19:25

Ustaw LC_ALL na:
LC_ALL="en_US.UTF-8"

oraz LANG na:
LANG="en_US.UTF-8"

Albo jeśli dalej ten perl będzie pluł, obydwie zmienne ustaw na "C".

Dla bash'a to będzie:
export LC_ALL="en_US.UTF-8" LANG="en_US.UTF-8"
,,Myślenie nie jest łatwe, ale można się do niego przyzwyczaić" - Alan Alexander Milne: Kubuś Puchatek

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1926
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [ubuntu 18.04] problem z ustawieniami (?)

Postautor: wojtek » poniedziałek 20 sie 2018, 07:33

Dzięki, tak ustawienie na en_US.UTF-8 jest ok, ale trzeba to wykonać dokładnie według https://wiki.yoctoproject.org/wiki/Tips ... caleIssues no i na koncie chroot ;) - ale jest to już opanowane.
73 Wojtek


Wróć do „GNU/Linux”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość