[Eclipse] AVRDUDE 6.1

Pytania dotyczące problemów z wyborem, konfiguracją i pracą w wybranym środowisku: Eclipse, Atmel Studio 6, CodeBlocks, a może jeszcze inne?
Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

[Eclipse] AVRDUDE 6.1

Postautor: wojtek » piątek 04 mar 2016, 09:07

Potrzebuję skompilowaną pod windows wersję 6.1 avrdude - bo ta obsługuje JTAG ICE 3. Ktoś ma?
73 Wojtek

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.1

Postautor: wojtek » piątek 04 mar 2016, 11:32

Tak znam te strony, ale właściwie chyba stabilną wersja przynajmniej pod linuxem była wersja 6.0.1 - dzisiaj sprawdziłem i taka pod linuxem mam
73 Wojtek

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.1

Postautor: wojtek » piątek 04 mar 2016, 19:52

Hmm i mam zagadke, a ze eclipse i avrdude nie jest moim "naturalnym" środowiskiem, to pytam. Czego to ode mnie może chcieć? odmawiając współpracy z każdym z posiadanych programatorów i twierdząc że ma problem z usb, pod AS7 kazdy programator chodzi az miło.
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.
73 Wojtek

Awatar użytkownika
Antystatyczny
Geek
Geek
Posty: 1096
Rejestracja: czwartek 03 wrz 2015, 22:02

Re: [Eclipse] AVRDUDE 6.1

Postautor: Antystatyczny » piątek 04 mar 2016, 20:17

Wątek dotyczy AVRDUDE 6, a tutaj na liście masz ATB-RS232 ATNEL, co wskazywałoby, że jednak masz wersję 5.11. Wersja 5.11 oczywiście powinna współpracować z np. USBASP, ale wystąpi dokładnie ten sam problem z obsługą ICE mkII, który miałeś pod linuksem. Wytnij z dysku wersję 5.11 i zainstaluj nowszą - np. 6.1 - ta w pełni współpracuje z eclipse. W eclipse wskazujesz na zainstalowany avrdude i tyle... MUSI działać :)
"The true sign of intelligence is not knowledge but imagination" Albert Einstein.

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.01

Postautor: wojtek » piątek 04 mar 2016, 20:44

a to nie ma znaczenia bo na jednym i drugim avrdude to samo jest; wersja 6.01, 6.1 i starsza tak samo reaguje, ten sam układ i programatory na AS7 działają
sprawdzam na avrispmkII (oryginał z ATMEL) tez lipa, ale ten sam komunikat na jtagice3
73 Wojtek

Awatar użytkownika
Antystatyczny
Geek
Geek
Posty: 1096
Rejestracja: czwartek 03 wrz 2015, 22:02

Re: [Eclipse] AVRDUDE 6.1

Postautor: Antystatyczny » piątek 04 mar 2016, 20:51

wojtek pisze:odmawiając współpracy z każdym z posiadanych programatorów


USBASP też Ci nie działa w eclipse? A z linii poleceń sprawdzałeś?
"The true sign of intelligence is not knowledge but imagination" Albert Einstein.

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.1

Postautor: wojtek » piątek 04 mar 2016, 21:35

Widzisz zapomniałem o USBASP, że go mam też (to czwarty :) ) - ten działa. JTAGICE3, ATMEL-ICE oraz ATMEL AVR ISP mkII nie działają
73 Wojtek

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.1

Postautor: wojtek » sobota 05 mar 2016, 07:01

Jest postęp, zapomniałem w przypadku JTAGICE3 i AVRISP mkII o libusb ze moge nie mieć, bo w sumie jak pisałem eclipse w zasadzie nie używałem do tych celów - https://sourceforge.net/p/libusb-win32/wiki/Home/ a konkretnie to warto mieć https://sourceforge.net/projects/libusb ... -releases/ - po zainstalowaniu AVRISP mkII działa bez problemu natomiast JTAGICE3 jeszcze ma jakiś problem
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.
73 Wojtek

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.1

Postautor: wojtek » sobota 05 mar 2016, 11:00

Ok, podsumowując:
1. Jakakolwiek zmiana libsów tak aby moje programatory działały pod eclipse (jeśli to by się ostatecznie wogóle udało - patrz post wyżej) powoduje, że przestają działać w moim głównym narzędziu jakim jest AS7.
2. można bawić się z filtrowaniem libsów ale to też nie zawsze się udaje, albo za kazdym razem gdybym zmienił IDE to musiałbym zmieniać libusb - to nie dla mnie.

Wniosek:
1. Zostawiam jak mam czyli AS7 i działające pod nim JTAGI i AVRISP mkII
2. Eclipse gdybym musiał z kimś się projektem (robionym pod Eclipse) wymieniać, sprawdzać itp. (ostatnio się nawet przydało do tego celu) i działający pod nim USBASP
3. Pod linuxem w eclipse działa mi również JTAGICE3 (i o dziwo bez problemu jaki na razie miałem pod win) i tam tak może zostać bo i tak pod lin nie działam na AS7.
73 Wojtek

Awatar użytkownika
Antystatyczny
Geek
Geek
Posty: 1096
Rejestracja: czwartek 03 wrz 2015, 22:02

Re: [Eclipse] AVRDUDE 6.1

Postautor: Antystatyczny » sobota 05 mar 2016, 12:31

Myślę, że cały szkopuł tkwi w przełączaniu sterownika w windowsie. Poza tym nie odpalaliśmy AS7 w linuksie i nie wiemy, czy nie byłoby identycznego problemu, jaki obecnie jest w windows :)
"The true sign of intelligence is not knowledge but imagination" Albert Einstein.

Awatar użytkownika
wojtek
Geek
Geek
Posty: 1928
Rejestracja: piątek 04 wrz 2015, 09:03
Lokalizacja: JO90JK

Re: [Eclipse] AVRDUDE 6.1

Postautor: wojtek » sobota 05 mar 2016, 12:58

No o tym piszę wyżej, że problem tkwi w przełaczaniu sterowników i wglębiać się w to nie bedę, gdyż szkoda czasu , mama narzędzie które mi działa, jedynie chciałem sprawdzić ponownie o co tyle krzyku z tym eclipse i widzę, że podobnie jak z linuksem tak i z eclipse przynajmniej w przypadku AVR mi nie po drodze.
73 Wojtek


Wróć do „Jakie IDE dla AVR?”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość